Nigeria National ID Provider is now available
Incident Report for Appruve
Resolved
This incident has been resolved.
Posted May 13, 2022 - 18:00 UTC
Investigating
We are currently investigating this issue.
Posted May 13, 2022 - 17:00 UTC
This incident affected: Appruve Identity Nigeria (Nigeria National ID API).