Nigeria Driver License ID Provider is now available
Incident Report for Appruve
Resolved
This incident has been resolved.
Posted Apr 28, 2021 - 03:00 UTC
Investigating
We are currently investigating this issue.
Posted Apr 26, 2021 - 17:00 UTC
This incident affected: Appruve Identity Nigeria (Nigeria Driver License ID API).