Ghana TIN Provider is not available
Incident Report for Appruve
Resolved
This incident has been resolved.
Posted Apr 15, 2021 - 08:49 UTC
Monitoring
The issue has been identified and we are monitoring resolution by our Provider
Posted Apr 13, 2021 - 13:20 UTC
This incident affected: Appruve Business Ghana (Ghana TIN API).