Nigeria Driver License ID Provider is now available
Incident Report for Appruve
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 05:00 UTC
Investigating
We are currently investigating this issue.
Posted Jan 13, 2022 - 23:00 UTC
This incident affected: Appruve Identity Nigeria (Nigeria Driver License ID API).