Nigeria Driver License ID Provider is now available
Incident Report for Appruve
Resolved
This incident has been resolved.
Posted Apr 25, 2021 - 23:01 UTC
Investigating
We are currently investigating this issue.
Posted Apr 25, 2021 - 22:00 UTC
This incident affected: Appruve Identity Nigeria (Nigeria Driver License ID API).