Nigeria Driver License ID Provider is now available
Incident Report for Appruve
Resolved
This incident has been resolved.
Posted Apr 24, 2021 - 17:01 UTC
Investigating
We are currently investigating this issue.
Posted Apr 23, 2021 - 13:00 UTC
This incident affected: Appruve Identity Nigeria (Nigeria Driver License ID API).