Ghana TIN Provider is not available
Incident Report for Appruve
Resolved
This incident has been resolved.
Posted Mar 26, 2021 - 14:12 UTC
Monitoring
We are currently monitoring the TIN service provider for resolution.
Posted Mar 25, 2021 - 13:12 UTC
This incident affected: Appruve Business Ghana (Ghana TIN API).